Tu servidor está ejecutando la versión 4.4.9 de PHP, pero WordPess 3.8.1 necesita, al menos, la versión 5.2.4.